Can't access the http://ip-address-of-rpi:2015/ after run visionappster engine

  • Hi,
    I tried to install the visionappster platform to my device by installing the va-install, visionappster.flatpak and the runtime-freedesktop.flatpak
    The output of flatpak info com.visionappster.Builder is

    app/com.visionappster.Builder/x86_64/master com.visionappster.Builder-1-origin d86bf40b4443d51d4a48abc5aae94262ff541c2c43cd1291c53425f7a8bd05a7

    But when I tried to run flatpak run com.visionappster.Builder, I got this error:

    error: runtime/org.freedesktop.Platform/x86_64/18.08 not installed

    Even though, I think I have installed the build-bundle runtime-freedesktop.flatpak which already includes the org.freedesktop.Platform?

    And when access to the browser: http://ip-address-of-rpi:2015/, I got nothing. Are there any possibilities of what I've done wrong?
    Or do you have any suggestion to test the installation or what are the missing files?

  • Hi,

    Can you report your operating system version so that we can try to reproduce the error? What does uname -a output if you type it to your shell?

    When it comes to the connection problem I'm not sure what you are trying to achieve. Are you running a Raspberry Pi with our Engine? Or did you try to connect to a locally running Engine instance?

    When installing with va-install you have the option to install the Engine as a local service. Did you choose that option? If yes, then http://localhost:2015 should do the trick. That is, unless the Engine also fails to start.

    If you are trying to connect to a Raspberry Pi, "ip-address-of-rpi" needs to be replaced with the IP address of the Raspberry Pi. See here for instructions.


  • @Topi Hi,
    I am using a company device (not a Raspberry Pi).
    The output of uname --a is

    Linux  4.4.113-yocto-standard #2 SMP PREEMPT x86_64 x86_64 x86_64 GNU/Linux

    So I use flatpak build-bundle to create a bundle from directory /var/lib/flatpak/repo in my host machine (which installed the org.freedesktop.Platform//18.08).
    Then, I installed that bundle to the device.
    Is there anyway to check if the VisionAppster Engine is running in our device?
    And from http://localhost:2015, can I connect to our device by adding IP address in "Cameras" section? And then upload the .vapkg, and start it with the device?
    And yes, I did repalce the "ip-address-of-rpi" by our device IP address.

  • Hi,

    Oh, you are using an OpenEmbedded -based custom distro? Making flatpak work on home-grown Linux distributions if unfortunately something we currently cannot help with. Furthermore, flatpak is targeted at desktop and not the best choice if your target is to run the VisionAppster Engine on an embedded system.

    Unless you want to run the Builder on the target hardware, I propose that you use the va-engine docker image instead. It has much lighter dependencies. Basically, you only need a shell and a few utility programs (see here).

    That said, systemctl status va-engine will tell you if the Engine is running. If you use the docker image, the command is docker ps.


  • @Topi Hi,
    So what is your suggestion to run the VisionAppster Engine on embedded system instead of flatpak?
    Because my aim is to receive the images capture by the device. And as I understand, I just need to have the VisionAppster Engine running inside the device. So I don't necessary need the Builder?

    And I think that the va-engine is not installed properly because I tried systemctl status va-engine and here is the result:

    Unit va-engine.service could not be found

    Theoretically, if I install the va-install, the Engine service should be running right?

  • The flatpak installer contains the Builder although it also gives you an option to install the Engine as a local service if you don't want to fiddle with docker. The Builder is an IDE for creating new vision apps. You don't need it in an embedded environment.

    It is possible to use the flatpak installer in a Yocto-based distro (I know one customer who has done so), but it may be challenging because it basically requires a full desktop environment. If the Builder from the flatpak installation doesn't work, there is little hope that the va-engine service inside it will either.

    My suggestion is to go with the docker image. It is way easier to set up in a custom embedded system. Unfortunately we don't have ready-made installation instructions.


Log in to reply