Could not load analysis engine. Error while loading engine: Unregistered class



  • Hi,
    So I installed .vapkg file and it has the yellow warning as:

    Could not load analysis engine. 
    Error while loading engine: Unregistered class.
    

    What does this warning mean? And how can I fix it?
    And also I realized that the .vapkg file is made for VisionAppster version 3-beta4, but I used the version3-beta2 of my device, so does it affect anything (I am not the person who developed the vapkg files so I'm not really used to it)
    Here is the output of

    systemctl status va-engine
    
    [[0;1;32m●[[0m va-engine.service - VisionAppster Engine
       Loaded: loaded (/etc/systemd/system/va-engine.service; enabled; vendor preset: enabled)
       Active: [[0;1;32mactive (running)[[0m since Wed 2020-04-15 06:22:58 UTC; 2h 55min ago
     Main PID: 290 (flatpak-bwrap)
       CGroup: /system.slice/va-engine.service
               ├─290 /usr/libexec/flatpak-bwrap --args 7 va-run /opt/visionappster/init/init.qml webServer=0.0.0.0:2015
               ├─310 /usr/libexec/flatpak-bwrap --args 7 va-run /opt/visionappster/init/init.qml webServer=0.0.0.0:2015
               └─315 va-run /opt/visionappster/init/init.qml webServer=0.0.0.0:2015
    
     flatpak[290]: GET /manager/properties/runningApps
     flatpak[290]: GET /apis/
     flatpak[290]: POST /manager/functions/startOnce
     flatpak[290]: qml: Error while loading engine: Unregistered class
     flatpak[290]: Could not load analysis engine.
     flatpak[290]: Error while loading engine: Unregistered class
     flatpak[290]: Could not load analysis engine.
     flatpak[290]: Error while loading engine: Unregistered class
     flatpak[290]: GET /manager/properties/runningApps
     flatpak[290]: GET /apis/
    


  • @dantcamui This error generally means that the version of the engine that you have installed does not recognize some of the tools used in your app. Running it in the same (or newer) VisionAppster release as the one the app was created with should fix it.


Log in to reply